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Overview

Chess Browser is a program for viewing and editing chess games.  Chess 
Browser uses a standard format known as PGN (Portable Game Notation).  Most 
current chess programs can read PGN files.

Some of the notable features of Chess Browser include a Chess Game 
Library which makes it easier to find the game you are looking for, a simple 
intuitive method for quickly replaying games, easy importing of games recorded by 
Yahoo Chess, and easy text entry of moves.

Chess Browser does NOT play chess.  It is meant to be a method for easily 
storing and playing back games, not as a program to play against.

Chess Browser requires Mac OS X.

About Chess Browser

Chess Browser was written by Kevin L. Gong.  It is copyright 2002 by Kevin L. 
Gong.  It may be freely distributed so long as it is distributed in unmodified form 
with all accompanying documentation.  Distribution via fee-based methods (for 
example, CD’s or DVD’s sold to the public) is strictly prohibited without the 
expressed written consent of Kevin L. Gong.

Shareware Registration

Chess Browser is a shareware application.  This means you are free to try it 
out, but if you decide to use it you must pay the shareware registration fee.  
Currently, the fee is just $8 (US dollars).

If you pay the fee, you will receive a registration code which will prevent the 
shareware notice from coming up every time you launch Chess Browser.  You’ll also 
receive free lifetime upgrades.

To register, simply go online and visit the registration page:

http://order.kagi.com/?XY5

Payment is accepted via credit card, check or money order, or cash of any 
major type of currency.

Once your payment is accepted, you will be emailed a registration code.  
Select Enter Reg Code... from the Chess Browser menu and enter that code.

About PGN Files

Chess Browser reads and writes PGN files.  PGN (Portable Game Notation) is 
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a standard way to save chess games.  PGN files are readable text files.  If you like, 
you can edit them by hand with any text editor.  The basic format is a section of 
tag/value pairs (providing information like date, site, round) followed by the 
moves.  Here is a sample PGN file:

[Date "1986.04.04"]
[Result "1-0"]
[White "Kevin Gong"]
[Black "Tuy Buckner"]
[Round "1"]
[Site "Berkeley, CA"]
[Event "Berkeley Chess Club April 1986"]
[BlackUSCF "1351"]
[WhiteUSCF "0"]

1. d4 d5 2. Nc3 Nf6 3. Nf3 b6 4. Bf4 Ba6 5. g3 e6 6. Ne5 Bd6 7. e3 Bxf1 8. Rxf1
Nbd7 9. Qd3 O-O 10. O-O-O Bxe5 11. Bxe5 Ng4 12. f3 Ndxe5 13. dxe5 Nxe5 14. Qd4
f6 15. e4 c5 16. Qa4 Nc4 17. Rfe1 d4 18. Qxc4 Qd6 19. f4 Kh8 20. Nb5 Qc6 21.
Nxd4 b5 22. Qxb5 Qb6 23. Qxb6 axb6 24. Nxe6 Rfe8 25. Nc7 Rxa2 26. Nxe8 c4 27.
Rd8 g6 28. Nd6+ Kg7 29. e5 b5 30. exf6+ Kxf6 31. Nxb5 Ra5 32. Rd6+ Kg7 33. Nd4
Ra7 34. f5 c3 35. bxc3 Ra1+ 36. Kd2 Ra7 37. fxg6 hxg6 38. h4 Ra5 39. Rd7+ Kh6
40. g4 Ra6 41. Re6 Rxe6 42. Nxe6 g5 43. hxg5+ Kg6 44. Rg7# 1-0

The order of the tag/value pairs is not important.  For a complete specification of 
the PGN file format, visit the Chess Browser web site at 
http://kevingong.com/ChessBrowser/.

PGN files may contain more than one game.  In fact, a single PGN file may contain 
dozens, hundreds, or even thousands of games.  The games are simply 
concatenated together into one file; there is no additional information in the file to 
separate games.  To avoid confusion, I will refer to single-game PGN files and 
multi-game PGN files to distinguish the two.  Chess Browser can read both single-
game and multi-game PGN files.  However, it can currently only write single-game 
PGN files.  Chess Browser can handle large PGN files -- I have used it to open a 
PGN file over 2MB in size.  It did handle a bit sluggishly, but otherwise seemed to 
work fine.

You can find many existing PGN files on the web, especially for games between 
grandmasters.  See the Chess Browser web site for a list of sites with PGN files.  Or 
simply do a web search for “PGN files.”

Chess Browser does correctly parse PGN files with move annotations, recursive 
annotation variations, and comments.  However, the annotations, variations, and 
comments are ignored and will not be written out if you subsequently save the file.  
This feature will be added in a future version of Chess Browser.

Chess Game Library

At the heart of Chess Browser is the Chess Game Library.  The library is a list 
of chess games in separate PGN files.  You can use the Chess Game Library to 
keep track of all of your own games, or Kasparov’s or Fischer’s games.  You can 
keep all these games in your library and easily sort and search to find what you’re 
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looking for.

When you first run Chess Browser, you will see the Chess Game Library window.  It 
will have a few sample games in it.  You can add and delete games easily.  The 
library is saved so that if you quit Chess Browser, the list will be restored the next 
time you run Chess Browser.  If you don’t want the library to appear automatically, 
unselect Show game library on launch in the Preferences.

Chess Game Library

There are two ways to add games to the library.  By default, every game you open 
or save will be added to the library.  If you do not want this to occur, you can un-
check Automatically add games to library in the Preferences.  Then, to add a 
game to the library, you must select Add Game To Library in the Library menu; 
this will add the frontmost game to the library.

When you add a game to the library, a copy is saved in the Chess Browser Data 
folder in the Documents folder.  When you subsequently try to view games in the 
library, Chess Browser tries to open the original PGN file.  However, if you have 
moved or deleted the original file, then the copy is opened.

If Automatically add games to library is checked in the Preferences, then 
whenever you edit the original PGN file, the changes are reflected in the game 
library.  If the option is not checked in the preferences, then you can update 
manually by selecting Update Game In Library.
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Preferences

You may sort the list of games by any of the columns (date, white, black, etc.).  
Simply click on the column heading.  Click on it again to reverse the order.

You can search the library using the field on the bottom right of the library window.  
First, select, the type of search you want to perform from the pop-up menu.  Then 
type in the keyword(s) you would like to search for.  The search will be performed 
automatically as you type; there is no need to press the return key or click any 
button.  Only the games which match your search will be shown.  Clear the field to 
again see all the games.

To view a game in the library, select it in the list and click the View button.  
Alternatively, you can hit the Return key.  As a short cut, you may also double-click 
a game in the list to view it.

To remove a game from the library, select it in the list and click the Remove 
button.  Alternatively, hit the Delete key.  In either case, a dialog will appear 
asking you to confirm.  If you don’t want this dialog to appear, you can unselect 
Show dialog to confirm removals in the Preferences.  When you remove a game 
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from the library, the copy in the Chess Browser Data folder is deleted; the original 
file is left untouched.

Replaying Games

Chess Browser provides an easy interface for replaying games.

Chess Game View

Use the View menu to view the game from White’s perspective (Black on Top) or 
from Black’s perspective (White on Top).
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View menu

Click the > button to play the next move and the < button to go back one move. 
Alternatively, you can use hit the space bar to play the next move and the delete 
button to go back one move.

Use the slider to jump to any move.  The text below the board displays the current 
move.  You may also click on a move in the list of moves on the right to jump to 
that move.

You can view moves in short algebraic or long algebraic notation by changing the 
Preferences.

Use the History menu to Jump to start, Jump to end, or Jump to... a move 
number.

History menu

Select Start auto-play from the History menu to begin automatic playback of the 
game.  The moves will be played automatically one by one from the current 
position, ending when there are no more moves.  A drawer will show up, allowing 
you to change the playback speed.  Use the slider to adjust the speed faster or 
slower.  The progress indicator shows you the duration between moves.  Click the 
Stop button at any time to stop auto-play, or select Stop auto-play from the 
History menu.  Click the Hide drawer button to hide the drawer; in this case, auto-
play continues but the drawer is hidden.  You can show the drawer again by 
selecting Auto-play speed... from the History menu.
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Auto-play drawer

Entering Moves

You can create a new game by selecting New from the File menu.  A new 
game viewer window will appear with an empty move list.

To begin entering moves, double-click on the space for White’s first move.  
After you enter each move, you can press the tab key to go on to the next entry.

You can enter the move in short algebraic or computer algebraic notation.  
For example, you can enter Nc3 or b1-c3.  Chess Browser is somewhat forgiving 
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and will try to interpret your entry as best it can.  If it cannot decipher a move, it 
will ask you to try again.  If you are having trouble entering a move, computer 
algebraic is your best bet.  Note that you can enter moves in either format, 
regardless of your current notation setting in the preferences.

As you enter moves, the board will display the current position.

Currently, Chess Browser will not let you drag pieces to enter moves.  This 
capability may be added to a future version.

Editing Game Information

There are two ways to edit game information.

To edit the standard game information, click the Edit button in the game 
window.  Alternatively, select Edit Player/Date Info in the Edit menu.  In either 
case, a sheet will appear allowing you to edit the standard game information.

Edit Game Info Sheet

You may enter the date in a format other than year.month.day if you wish; 
the program is intelligent enough to convert it to the appropriate format.  For 
example, “April 4th, 1986” would work.

To edit other game information, click the More Info button in the game 
window.  A drawer will appear with a list of tag/value pairs.  You can edit any field 
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by first double-clicking on it, then typing the new entry.  To add a new tag, click the 
Add New Tag button.  To close the drawer, click the More Info button again.

More Information Drawer

Opening/Saving/Importing Games

You can open single-game or multi-game PGN files by selecting Open... 
from the File menu.  PGN files should be text files with the extension .pgn.  If the 
file is a single-game PGN file, it will be displayed in a game window.  If the file is a 
multi-game PGN file, the games will be listed in a new window similar in appearance 
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to the library window.  You can then view individual games from that list.

You can open single-game or multi-game PGN files by selecting Open... 
from the File menu.  PGN files should be text files with the extension .pgn.  If the 
file is a single-game PGN file, it will be displayed in a game window.  If the file is a 
multi-game PGN file, the games will be listed in a new window similar in appearance 
to the library window.

Game list window

Chess Browser currently can only save single-game PGN files.

If you play Yahoo Chess, you can use Chess Browser to save the games you play.  
First, when you’ve completed a game in Yahoo Chess, have the game history sent 
to you via email.  Then, in Chess Browser, select Import From text... in the File 
menu. Paste in the text of the game history email into the text dialog and click 
Import.  Chess Browser will import all the moves, along with the title, date, and 
white and black players.  Unfortunately, the game history email does not currently 
include game result or player ratings, so you will have to enter that yourself.
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Import from Text dialog

Alternatively, if you’ve saved the email as a text file, you can choose Import from 
file...   from the File menu.  Actually, Import from file... behaves exactly the same 
as Open..., and either will allow you to open a PGN file or import a Yahoo chess 
game.

Note that Chess Browser handles the format of Yahoo Chess games as of June 
2002.  If Yahoo subsequently changes the format of the email history, this feature 
may not work correctly.  However, I will do my best to keep this feature up-to-date.

Resources

For more information, please visit the Chess Browser web site at 
http://kevingong.com/ChessBrowser/ .

Please also visit the web site to submit feedback or bug reports.  As this is 
the first version of Chess Browser, your feedback is greatly encouraged to help 
shape future versions.
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